Skip to main content

Supported audio formats


Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 7587

Struct fields

Playback example

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 3640

Struct fields

Playback example

The forma.Config field contains the parsed AudioSpecificConfig, including SampleRate and ChannelCount. Check this before configuring any downstream AAC decoder.
Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 3551

Struct fields

Usage

The standard static payload types (0 = PCMU, 8 = PCMA) are detected automatically from the SDP. Dynamic payload types support non-standard sample rates.
Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 3190, RFC 3551

Struct fields

Usage

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 4184

Struct fields

Usage

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 3551Static payload type: 9

Struct fields

Usage

Formats without built-in encoder/decoder

The following formats are recognized and parsed from SDP, but do not provide CreateEncoder() or CreateDecoder() methods. You must supply your own RTP packetizer and depacketizer.
For these formats you can still receive raw RTP packets via OnPacketRTP and implement your own framing logic: