Skip to main content

Supported video formats


Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 6184

Struct fields

Recording example

Declare the format when starting a recording session:

Playback example

rtph264.ErrNonStartingPacketAndNoPrevious and rtph264.ErrMorePacketsNeeded are non-fatal: the decoder is waiting for more packets to reassemble a complete access unit.
Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 7798

Struct fields

Playback example

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RTP Payload Format For AV1 (v1.0)

Struct fields

Playback example

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 9628

Struct fields

Usage

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 7741

Struct fields

Usage

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 2435Static payload type: 26

Struct fields

Usage

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 6416, section 7.1

Struct fields

Usage

Package path: github.com/bluenviron/gortsplib/v5/pkg/formatSpecification: RFC 2250Static payload type: 32

Struct fields

Usage